Problem:


Email is not sent even if alarm is generated. Issue while sending email.



Analysis Steps:


1. Check the email configuration in PLS_WebServerConfig.PROPERTIES located in enviroconect folder.
(webapps\enviroconect\conf\ PLS_WebServerConfig.PROPERTIES)

2. Check SMTP details 




SmtpHostName=10.6.10.2

SmtpUserName=plantconnectsupport@aiplindia.com

SmtpPassword=smtppassword

SmtpPortNo=30

EmailFrom=plantconnect.support@aiplindia.com

SSL=true

STARTTLS=true

3. Ask customer to verify these configured details are correct.

4. If the details are correct then test by 'Email test utility' as shown below:


 




Case 1:


If the username or password configured is wrong then the error appears as shown below:



Root Cause:


Wrong details are configured 



Solution:


Ask customer to give correct details



Case 2:


Mail sending fails and gives error as 'the transport failed to connect to the server'.



Root Cause:


If there are any security settings/ restrictions in customer's network then, this type of error occurs


Solution:


Ask customer's IT person to c allow mail through their network.




Problem:


SMS is not sent even if alarm is generated. Issue while sending SMS.



Analysis Steps:

1. Check the SMS gateway configuration in PLS_WebServerConfig.PROPERTIES located in enviroconect folder.
(webapps\enviroconect\conf\ PLS_WebServerConfig.PROPERTIES)

2. Check details as highlighted below



#smsGatwayToUse=Clickatell

smsGatwayToUse=bulksms

#GatewayId=clickatell.http.1

GatewayId=bulksms.http.1

SUserName=PlantConnect

SPassword=plantconnect

SenderId=abc

Priority=4