Problem
Communication failure between DAS and server
Analysis Steps:
Run RTDAS manually
Check PLSLog file
Refer following sample cases for further details:
SR No | Error message |
Case 1 | Error message in PLSLogs seen as DAS cannot be started |
Case 2 | Error in opening/reading file PLSConfig |
Case 3 | Could not load the requested DLL |
Case1: In PLSLog file, following error is found as:
‘DAS cannot be started. Cannot connect to server and siteconfig file doesn’t exist…...’
Root cause:
If server is on cloud and internet connection is not proper of PC/DATCon on which RTDAS is installed then RTDAS cannot communicate with server.
If server and RTDAS is on the different PC/DATCon but are in same network. And if port 8080 connection is not enabled from server PC.
Solution:
Make sure internet connection is proper, test by ping command from PC/DATCon. Ping google(8.8.8.8) or server IP. If not then contact IT person of customer.
Check if port is enabled in firewall, if not then add rule
Open Windows Firewall with command “wf.msc”
Following is Windows Firewall with Advanced Security.
Click on Inbound rule then click on New rule in right corner.
Add New rule as per snapshots:
Choose Port and then click on Next.
Add respective port numbers for Tomcat and FTP Server.
Give name to Inbound Rule for future reference.
Case 2: Error in opening/reading file PLSConfig
Root cause:
PLSConfig is not present or it is empty.
Solution:
Download PLSConfig file from server for respective site and place it in EnviroConnectDAS/ DATCon folder.
Case: 3
In PLSLog file, following error is found as:
‘Could not load the requested DLL.
Device creation failed. Device information received is - .......’ as shown below
Root cause:
As per the configured protocol, the same driver DLL is not present in DAS folder.
Solution:
Check which protocol is configured on server and place relative driver file.
e.g. If protocol is ModbusRTUMaster then ModbusRTUMaster.dll should be present in DAS folder